Parent App Login issues

Minor incident School MIS
2023-07-18 11:01 BST · 2 weeks, 6 days, 22 hours, 20 minutes

Updates

Resolved

Our engineering team has pushed out many fixes to the login logic via the app and the issue should now be resolved

August 2, 2023 · 16:17 BST
Investigating

We recognize that a small number of parents/guardians have experienced an issue when entering credentials on the Arbor app. We are currently investigating this issue, which is limited to the mobile app. Whilst we continue to triage this issue the parent portal continues to be available

July 18, 2023 · 11:01 BST

← Back