Arbor Navigation issue

Minor incident School MIS
2023-12-07 15:32 BST · 23 minutes

Updates

Resolved

Site navigation should be appearing as expected, please let us know if you encounter any issues accessing certain areas of Arbor.

Thank you again for bearing with us whilst we fixed this. We’re really sorry and understand this will have impacted operations this afternoon.

December 7, 2023 · 15:55 BST
Issue

We are aware that customers are experiencing issues with navigation in Arbor. Our engineers are working on a fix as a priority, this should be released soon. We would like to thank customers for their patience whilst we work on this.

December 7, 2023 · 14:43 BST

← Back