19.01.2024

Major incident School MIS MAT MIS
2024-01-19 10:40 BST · 26 minutes

Updates

Resolved

The issue with some customers experiencing issues with Arbor loading has now been resolved.

Thank you for your patience whilst we worked on fixing this.

January 19, 2024 · 11:00 BST
Issue

We’re aware that some customers are experiencing issues accessing Arbor this morning. This is being investigated as our highest priority and an update will be posted here shortly.

We’re very sorry for any disruption this is causing.

January 19, 2024 · 10:47 BST

← Back