Actions undertaken are not processing

Major incident School MIS
2024-01-19 12:18 BST · 18 minutes

Updates

Resolved

The issue should now be resolved.

January 19, 2024 · 12:36 BST
Issue

We are currently experiencing issues with certain actions not completing, While we investigate please try not to re-action anything that is failing.

January 19, 2024 · 12:08 BST

← Back