Arbor Ticketing Service Emails not Sending

Major incident School MIS MAT MIS
2025-01-15 13:40 GMT · 1 day, 20 hours, 7 minutes

Updates

Resolved

Thank you for being so patient while our team worked to resolve this issue. We have identified the root cause and put a fix in place.

We are now working to send out any emails that have not been received over the past couple of days.

January 17, 2025 · 09:43 GMT
Issue

We recognise that some customers are not receiving emails from Arbor Support at present.

We are working on resolving this issue as an urgent priority. In the meantime, if you log into the Help Centre, you can see any updates to outstanding tickets open with Arbor.

January 17, 2025 · 09:16 GMT

← Back