Error messages appearing for some customers

Minor incident School MIS MAT MIS
2025-03-04 15:45 GMT · 16 hours, 2 minutes

Updates

Resolved

We’ve now resolved the errors that customers were experiencing when using Arbor.

We’re sorry for the disruption caused to your Tuesday and would like to thank customers for their patience whilst we worked on this.

March 4, 2025 · 17:17 GMT
Issue

We’re aware that some customers are experiencing error messages while on their Arbor site.

We apologise for the inconvenience and are currently investigating this issue as a priority.

March 4, 2025 · 15:45 GMT

← Back