Arbor Site Intermittent Unavailability and Slowness

Major incident School MIS MAT MIS
2025-04-08 11:32 BST · 22 minutes

Updates

Resolved

Customers can now access their Arbor sites as normal. A full retrospective of today’s incident will be carried out.

We’re sorry for any disruption caused and would like to thank customers for their patience while we resolved this issue.

April 8, 2025 · 11:43 BST
Issue

We recognise that some customers are experiencing an issue where they are encountering site unavailable messages on their Arbor site and system slowness.

We’re very sorry for any disruption caused to your morning and are working on this as an urgent priority.

April 8, 2025 · 11:38 BST

← Back