Data out of sync within the Data Warehouse

Minor incident Data Warehouse
2025-06-05 09:53 BST · 1 week, 1 day, 28 minutes

Updates

Resolved

Our engineers have resolved the issue with data within the Data Warehouse being out of sync and customers should no longer have issues when querying this data.

We’re sorry for any disruption this may have caused.

June 13, 2025 · 10:22 BST
Issue

We are aware of an issue where customers may experience missing or blank data in PowerBI dashboards. Please be assured that no data has been lost, the issue is specifically an availability issue we are currently investigating. We apologise for any inconvenience caused and thank you for your patience as we resolve this issue.

June 5, 2025 · 09:53 BST

← Back