Arbor Site Unavailability

Major incident School MIS MAT MIS
2025-09-26 09:40 BST · 15 minutes

Updates

Issue

Our engineers have implemented a fix for the issue some customers were encountering. Impacted customers can now access their Arbor sites as normal.

We’re sorry for any disruption caused and would like to thank customers for their patience while we resolved this issue.

September 26, 2025 · 09:55 BST
Issue

We recognise that some customers are experiencing an issue where they are encountering site unavailable messages and slowness on their Arbor site this morning.

We’re very sorry for any disruption caused and we are working on this as an urgent priority.

September 26, 2025 · 09:40 BST

← Back