Google Pay not working as expected on the Arbor Parent App

Information School MIS
2025-10-05 16:35 BST · 3 days, 15 hours, 31 minutes

Updates

Resolved

Our engineers have resolved the issue with Google Pay not working as expected on the Parent App.

We’re sorry for any disruption this may have caused and would like to thank customers for their patience whilst we worked on this.

October 9, 2025 · 07:58 BST
Issue

We are aware of an issue with the Arbor Parent App where users paying for items with Google Pay are unable to complete their purchase.

We are currently investigating this as a priority; in the meantime, users can pay with an alternative payment method through the Arbor Parent App without issue.

October 7, 2025 · 13:03 BST

← Back