Arbor Site Intermittent Unavailability and Slowness

Major incident School MIS MAT MIS
2025-10-20 10:47 BST · 1 hour, 26 minutes

Updates

Resolved

Our engineers have successfully implemented a fix for the issue, impacted customers should now be able to access their Arbor sites as normal.

We sincerely apologise for any disruption this incident caused and thank you for your patience while we worked to resolve this.

October 20, 2025 · 12:12 BST
Investigating

To accelerate service restoration and prevent further issues for impacted users, we are placing affected sites into Maintenance Mode.

Our teams are actively working to bring all services back online and stable.

October 20, 2025 · 11:36 BST
Issue

We recognise that some customers are experiencing an issue where they are encountering intermittent site unavailable messages on their Arbor site and system slowness.

We’re very sorry for any disruption caused to your morning and are working on this as an urgent priority.

October 20, 2025 · 10:45 BST

← Back