Arbor Site Unavailability
Major incident
School MIS
MAT MIS
2025-11-05 10:20 GMT
· 32 minutes
Updates
Resolved
November 5, 2025 · 10:50 GMT
Our engineers have successfully implemented a fix for the site loading and unavailability issues.
All impacted customers should now be able to access their Arbor sites as normal.
We sincerely apologise for the disruption caused this morning and would like to thank customers for their patience while we worked to resolve this incident.
Investigating
November 5, 2025 · 10:34 GMT
We are aware that some customers are currently unable to load their Arbor site this morning (sites are unresponsive or showing “unavailable” messages).
We sincerely apologise for the disruption. Our engineering team is fully engaged and investigating this as an urgent priority.
We will post the next update shortly.
← Back
Arbor Status