Arbor Student App Error
Minor incident
School MIS
2026-03-17 10:00 GMT
· 1 day, 51 minutes
Updates
Resolved
March 18, 2026 · 10:28 GMT
Our engineers have resolved the issue with the Arbor Student App not working as expected.
We’re sorry for any disruption this may have caused and would like to thank customers for their patience whilst we worked on this.
Issue
March 18, 2026 · 09:44 GMT
We are aware of an issue that some customers may be encountering with the Arbor Student App, where students are encountering an error when logging in.
We are currently investigating this as a priority; in the meantime, users can log in through the Arbor website without issue.
← Back
Arbor Status