Arbor Site Login Issues
Major incident
School MIS
MAT MIS
2026-05-26 15:31 BST
· 25 minutes
Updates
Resolved
May 26, 2026 · 15:54 BST
The login issues affecting Arbor sites today have now been resolved, and services are operating normally.
We sincerely apologise again for the disruption this caused to your day, and thank you for your patience while our teams worked to fix it.
Issue
May 26, 2026 · 15:31 BST
We are aware that some customers are currently unable to log in to their Arbor site today.
We sincerely apologise for the disruption this is causing. Our engineering team is fully engaged and investigating this as an urgent priority. We will post our next update as soon as we have more information.
← Back
Arbor Status