Arbor App Error

Minor incident School MIS
2026-06-22 09:34 BST · 4 hours, 33 minutes

Updates

Update

The login issue affecting the Arbor Student App has now been resolved.

Action Required for Students: To log back in successfully, students will need to update the app to the latest version via the App Store or Google Play Store.

Parent App Update: We are continuing to investigate login issues affecting the Arbor Parent App as a priority. In the meantime, parents can still access their accounts without issue by logging in via the Arbor website.

Thank you for your continued patience as we work to resolve the remaining issue.

June 22, 2026 · 10:47 BST
Investigating

We are currently investigating an issue affecting the Arbor App that is causing some users to encounter an error when logging in.

Resolving this is our top priority. In the meantime, users can successfully log in without issue via the Arbor website.

June 22, 2026 · 09:34 BST

← Back