Microsoft 365 Incident
Information
School MIS
MAT MIS
2026-09-04 10:00 BST
· 7 hours, 31 minutes
Updates
Resolved
September 4, 2026 · 16:15 BST
Microsoft have confirmed that this incident is now resolved and emails sent to and from users with Microsoft hosted domains should no longer experience delays.
Monitoring
September 4, 2026 · 15:59 BST
Microsoft is currently experiencing an active service incident (tracked as EX1467029) affecting Exchange Online, causing delays sending and receiving emails to and from external domains.
If you use a Microsoft-hosted email address (for example Outlook, Hotmail, or a work email on Microsoft 365), you may see delays in emails to or from our teams or those sent from Arbor while this is ongoing. Please do not re-try sending emails at this time.
We will continue to monitor Microsoft’s status page for any further updates.
← Back
Arbor Status