Arbor Site Errors and Slowness

Major incident School MIS MAT MIS API REST API GraphQL Partner Demo Sites Arbor Parent App Arbor Student App API Sandbox
2026-09-10 09:57 BST · 1 hour, 27 minutes

Updates

Post-mortem

Post Incident Report

What Happened

This morning, 10th September 2026, starting at 9:56 am, customers experienced increased page load times and intermittent errors. Our team identified the issue at 10:04 am, and as a precaution at 10:23 we began a rollback of the latest release. The issue continued despite the rollback; therefore confirming the issue was not related to the new release. The problem instead lay in an infrastructure configuration that impacted routine operations, causing 7-13% of requests to stall and time out.

How We Resolved It

Identified the Issue: We became aware of the slowdown at 10:04 am and began investigating immediately.
Initiated a Rollback: At 10:23 am, as a precaution, we began rolling back the recent release.
Failed Over to Fresh Infrastructure: As the rollback did not resolve the issue, at 10:51 am we began shifting traffic to a separate, freshly prepared set of servers unaffected by the underlying issue, to restore service more quickly.
Full Restoration: The transition was completed by 11:05 am, at which point all traffic was being served normally.

Preventing Future Issues

We are correcting the underlying infrastructure to remove the risk of a similar slowdown. We are also reviewing how our automated server-scaling system responds during incidents like this one to prevent it from adding further strain while an issue is being resolved.

We’re very sorry for the disruption this caused, and thank you for your patience while we worked to restore service this morning.

September 10, 2026 · 16:20 BST
Resolved

Our engineers have implemented a fix for the site unavailability and slowness issues. All customers should now be able to access their Arbor sites as expected. We will continue to monitor performance closely throughout the day and a full retrospective of today’s incident will be carried out.
We’re sorry for any disruption caused and would like to thank customers for their patience while we worked on this. A post-incident report will be available in due course.

September 10, 2026 · 11:05 BST
Investigating

We’re continuing to investigate the slow loading and site unavailability messages currently being experienced by customers. We are currently working on identifying the root cause as a priority.

We’re very sorry for any disruption caused and are working on this as an urgent priority.

September 10, 2026 · 10:47 BST
Issue

We recognise that some customers have been experiencing an issue where they are encountering intermittent errors messages and system slowness on their Arbor site.

We’re very sorry for any disruption caused and are working on this as an urgent priority.

September 10, 2026 · 10:24 BST

← Back